Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Install UltiDev passive mode
Maria
#1 Posted : Friday, September 9, 2016 6:04:33 AM(UTC)
Groups: Member
Joined: 9/9/2016(UTC)
Posts: 3

Hi!
I need to install the application in passive mode and register a web, all in a .bat

I try to do this:

msiexec.exe /qn /i "C:\Cassini\CassiniExplorerSetup.msi"
msiexec.exe /qn /i "C:\Cassini\CassiniServer2Setup.msi"
"%ProgramFiles%\UltiDev\Cassini Web Server for ASP.NET 2.0\UltiDevCassinWebServer2.exe" /register "C:\resources\Pruebas" 7ABEE8EC-5FFA-45f4-B881-6441D5B7C1E9 "Login.aspx" 80 /ignore

It seems to work because doesn't throw an error, but i can't access to web and if i go to cassini explorer nothing is register....




Later if i install "UltiDev Web Server Setup.exe" and execute the next command line, it works.

"%ProgramFiles%\UltiDev\Web Server\UWS.RegApp.exe" /r /AppID:{BFEA5241-1EAF-47C2-9E5B-ADE7AC9CE081} /Clr:2 /VDir:/Pruebas/autostart "/EndPoints:http://*:80/" "/Folder:C:\resources\Pruebas" "/AppName:Pruebas" /host:SharedNetworkService



I repeat, i need to do this in passive mode (without user window) but i don't know how. The first option do it but it doesn't work, and the second option i can't install "UltiDev Web Server Setup.exe" in passive mode...

Thanks!
Ultidev Team
#2 Posted : Friday, September 9, 2016 8:05:55 PM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,253

Thanks: 28 times
Was thanked: 59 time(s) in 58 post(s)
Hi,

You can run UltiDev.WebServer.msi using MSIEXEC.EXE in quiet mode. The MSI can be found in the "C:\Program Files (x86)\UltiDev\Web Server\Redist\Visual Studio" folder on the system where UWS is installed.

You may also consider building an installer using one of the installation authoring tools as described here:
http://ultidev.com/Forum...sing-Visual-Studio.aspx

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
Maria
#3 Posted : Monday, September 12, 2016 5:34:08 AM(UTC)
Groups: Member
Joined: 9/9/2016(UTC)
Posts: 3

If I execute "msiexec.exe /quiet C:/UltiDev.WebServer.msi" it shows the "Windows installer" window (like /?)
Ultidev Team
#4 Posted : Monday, September 12, 2016 12:31:25 PM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,253

Thanks: 28 times
Was thanked: 59 time(s) in 58 post(s)
Hi,

You can do "msiexec.exe /qn ..." to do quiet mode with no UI, just as you did for UltiDev Cassini MSIs.

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
Maria
#5 Posted : Thursday, September 15, 2016 11:25:02 AM(UTC)
Groups: Member
Joined: 9/9/2016(UTC)
Posts: 3

If i try to call with /qn it do the same like /?. I dont know why....
Ultidev Team
#6 Posted : Thursday, September 15, 2016 12:14:33 PM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,253

Thanks: 28 times
Was thanked: 59 time(s) in 58 post(s)
Hi,

We ran "msiexec.exe /qn /i UltiDev.WebServer.msi" and it ran perfectly fine and got installed without a problem.

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
Guest
#7 Posted : Tuesday, November 29, 2016 11:04:36 AM(UTC)
Groups:

Message was deleted by a Moderator.
Rss Feed  Atom Feed
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.