Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Cassini fails to install on some OEM Vista computers
Ultidev Team
#1 Posted : Tuesday, November 27, 2007 5:41:12 AM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,253

Thanks: 28 times
Was thanked: 59 time(s) in 58 post(s)
Who's affected
Users of some OEM Vista systems, predominantly using non-US version of Vista.

Problem manifestation
When installed by bundled product, UltiDev Cassini finishes installation without any error messages, but actually fails - no Programs menu items are created and Application Event Log has a cryptic MSIInstaller error entry stating among other things something like "Product: UltiDev Cassini Web Server Explorer -- Error 1001. (NULL) (NULL) (NULL) (NULL)"

Cause of the error
"Start Menu" Junction Point in the C:\ProgramData folder is broken. To check whether this is your problem, open Windows Explorer window, paste C:\ProgramData\Start Menu\Programs in the address bar and hit Enter. If you got an error message, then you are experiencing the same issue and the fix is below.

According to one of the users, the issue has to do with a bug in the OS image preparation utility ImageX.exe. The bug should have been fixed in Vista SP1.

Best Solution
Get a brand new UltiDev Web Server Pro.

Workaround
Please download this archive, unzip and save the BAT file on your Vista system, right-click the BAT file and click Run As Administrator. After that navigate to the C:\ProgramData\Start Menu\Programs to see if it's OK now. If you don't get any error messages, try installing UltiDev Cassini again.

If not, you may need to do a couple more manual steps:
- Go to C:\ProgramData, and use Tools | Folder Options -> View tab, to uncheck "Hide protected operating system files". This should result in quite a few junction points (links) to be shown.
- Right-click the "Start Menu" link/JP and then do Properties -> Security tab -> Edit button.
- Select Administrators in the top list and check "Full Control" box in Allow column of the Permissions section. Click OK as many time as it will be necessary, then run the BAT (as administrator) again and check whether you can get to the C:\ProgramData\Start Menu\Programs. If you can, then try installing UltiDev Cassini Web Server again.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
leandromg
#2 Posted : Thursday, May 8, 2008 9:23:31 AM(UTC)
Groups: Member
Joined: 5/8/2008(UTC)
Posts: 2
Location: Brazil

Hi!

I've found a more "user friendly" solution to this problem. I've got the same problem on a Windows Vista, Brazilian Portuguese version, without SP1. It's related to the way Visual Studio 2005 generates MSI instalation files, causing troubles with windows User Access Control (UAC) in Vista. MSI files builded by VS 2008 do not present the same problem.

So, the solution is here: http://hunter555.blogspo...e-2869-msi-and-uac.html

Or here: http://blogs.msdn.com/as...visual-studio-2005.aspx

I hope Ultidev Team make available fixed MSI Cassini files soon, avoiding future developers' problems.

Last but not least, Cassini is a great work! Congrats to Ultidev Team!

Best regards from Brazil,

Leandro
Ultidev Team
#3 Posted : Thursday, August 7, 2008 8:41:18 AM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,253

Thanks: 28 times
Was thanked: 59 time(s) in 58 post(s)
Leandro,

this seems to be a different issue than the once described above. Could you please let us know if the symptoms were the same. If so, we'll leave your post in this thread, otherwise we would like to move your post to a thread specially created for it. We would appreciate if you could write about how the problem manifested itself.

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
Guest
#4 Posted : Tuesday, August 26, 2014 2:44:20 AM(UTC)
Groups:

Message was deleted by a Moderator.
Guest
#5 Posted : Tuesday, August 26, 2014 12:27:49 PM(UTC)
Groups:

Message was deleted by a Moderator.
Guest
#6 Posted : Saturday, November 1, 2014 11:29:49 AM(UTC)
Groups:

Message was deleted by a Moderator.
Guest
#7 Posted : Wednesday, November 5, 2014 5:04:09 AM(UTC)
Groups:

Message was deleted by a Moderator.
Guest
#8 Posted : Saturday, November 8, 2014 3:49:09 PM(UTC)
Groups:

Message was deleted by a Moderator.
Guest
#9 Posted : Monday, December 7, 2015 11:19:21 PM(UTC)
Groups:

Message was deleted by a Moderator.
Guest
#10 Posted : Wednesday, March 15, 2017 6:09:48 AM(UTC)
Groups:

Message was deleted by a Moderator.
Guest
#11 Posted : Thursday, March 23, 2017 2:58:04 AM(UTC)
Groups:

Message was deleted by a Moderator.
Guest
#12 Posted : Monday, July 9, 2018 11:07:05 AM(UTC)
Groups:

Message was deleted by a Moderator.
Rss Feed  Atom Feed
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.