Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

ASP.NET Forms Authentication
Guest
#1 Posted : Friday, September 16, 2011 3:46:28 AM(UTC)
Groups:
Joined: 11/1/2005(UTC)
Posts: 278

I've set up a website that uses asp.net authentication. Every other aspect of the site works as it does under visual studio development server / IIS 6 except for the forms authentication.

Stepping through it I've seen the code authenticate the login but the necessary cookie never gets set so when I try to pick up the asp.net profile it doesn't exist.

I've swapped back and forth between UltiDev, Visual studio and IIS and the authentication consistently works on all but UltiDev. I've replicated the problem on 3 different machines and using different browsers. The site has been functioning correctly in a live environment under IIS for close to a year.

Any advice you're able to give would be great.

Thanks
Mark
Ultidev Team
#2 Posted : Friday, September 16, 2011 2:03:02 PM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,253

Thanks: 28 times
Was thanked: 59 time(s) in 58 post(s)
Hello, Mark.

This is very, very strange. We most certainly tested cookies a lot and we run several applications using cookie auth with no problem: ASP.NET cookie functionality adds Set-Cookie response header every time.

We are attaching a test Visual Studio 2010 project that we re-tested cookie functionality with. Feel free to run it and try to reproduce the problem. If is has no problem, then please send us your application, if you can, so we could try it too - we definitely need to take care of this potential problem if it's there. To attach files to your postings you will need to create an account with the forum. Or you can contact us to get our email address to send us your project privately.

Best regards,
UltiDev Team.
File Attachment(s):
WebApplicationTest.zip (160kb) downloaded 44 time(s).
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
Guest
#3 Posted : Monday, September 19, 2011 5:57:06 AM(UTC)
Groups:
Joined: 11/1/2005(UTC)
Posts: 278

Ultidev Team;2956 wrote:
Hello, Mark.

This is very, very strange. We most certainly tested cookies a lot and we run several applications using cookie auth with no problem: ASP.NET cookie functionality adds Set-Cookie response header every time.

We are attaching a test Visual Studio 2010 project that we re-tested cookie functionality with. Feel free to run it and try to reproduce the problem. If is has no problem, then please send us your application, if you can, so we could try it too - we definitely need to take care of this potential problem if it's there. To attach files to your postings you will need to create an account with the forum. Or you can contact us to get our email address to send us your project privately.

Best regards,
UltiDev Team.




Thanks for your response. I'm not actually able to run this project under Ultidev though. Is it missing some binaries?
Ultidev Team
#4 Posted : Monday, September 19, 2011 7:20:38 AM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,253

Thanks: 28 times
Was thanked: 59 time(s) in 58 post(s)
He there!

The project needs to be built first, but other than that, it should not have any dependencies.

What error do you get?

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
Ultidev Team
#5 Posted : Thursday, September 22, 2011 11:36:51 AM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,253

Thanks: 28 times
Was thanked: 59 time(s) in 58 post(s)
We have identified a bug: multiple cookies cannot be set. Next build will take care of the problem.

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
Ultidev Team
#6 Posted : Saturday, September 24, 2011 2:56:25 PM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,253

Thanks: 28 times
Was thanked: 59 time(s) in 58 post(s)
Build 10 is released.

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
Rss Feed  Atom Feed
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.