Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Ever Growing trace File - UWS.AppHost.Clr2.x86.trace
s.elliott2
#1 Posted : Monday, May 22, 2017 9:19:48 AM(UTC)
Groups: Member
Joined: 5/22/2017(UTC)
Posts: 3

Hi, We use Ultidev to support our installation of the Solarwinds Syslog Server.
There is a trace file continually being written to, UltiDev/Web ServerUWS.AppHost.Clr2.x86.trace.
I can manually remove or archive it every so often, but if I forget, it continues to consume disk space.
How do I turn off tracing?
Many thanks,
Ultidev Team
#2 Posted : Wednesday, May 24, 2017 9:33:01 AM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,247

Thanks: 28 times
Was thanked: 55 time(s) in 54 post(s)
Hi,

Sorry for delayed reply. Tracing has been turned on for some reason, and can easily be turned off.

- Please got to "C:\Program Files (x86)\UltiDev\Web Server".
- Open "Web ServerUWS.AppHost.Clr2.x86.config" in a text editor.
- Comment out trace section inside the system.diagnostics.
- Save the file, restart UWS.
Trace file should not be generated anymore.

Please let us know whether this information has helped.

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
s.elliott2
#3 Posted : Tuesday, May 30, 2017 3:10:55 AM(UTC)
Groups: Member
Joined: 5/22/2017(UTC)
Posts: 3

Hi there, thanks for your reply.
I checked the UWS.AppHost.Clr2.x86.exe.config file and trace appears to be disabled already.
So, I restarted the web server and deleted the old trace file, but a new trace file was generated immediately and continues to grow in size.
I've copied the contents of the UWS.AppHost.Clr2.x86.exe.config file below - what have I missed?
Many thanks,
Stephen

Note: removed brackets for forum post

system.diagnostics
!--trace autoflush="true" indentsize="4"
Ultidev Team
#4 Posted : Tuesday, May 30, 2017 8:57:22 AM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,247

Thanks: 28 times
Was thanked: 55 time(s) in 54 post(s)
Hi,

Please attach the config file to your post, instead of pasting the content.

All the best,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
s.elliott2
#5 Posted : Tuesday, May 30, 2017 9:14:34 AM(UTC)
Groups: Member
Joined: 5/22/2017(UTC)
Posts: 3

please see attached UWS.AppHost.Clr2.x86.exe.config file.
Thanks.
File Attachment(s):
UWS.AppHost.Clr2.x86.exe.config.txt (1kb) downloaded 6 time(s).
Ultidev Team
#6 Posted : Wednesday, May 31, 2017 12:17:40 PM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,247

Thanks: 28 times
Was thanked: 55 time(s) in 54 post(s)
Hi,

Unfortunately we can't tell what's going on. It should not be happening. We can try to suggest a work-around: please register your application with CLR4 (.NET 4), with same bitness of the host process, and please let us know whether it made any difference.

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
Rss Feed  Atom Feed
Users browsing this topic
Guest (2)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.