Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Authentication - Failure to access directories on server
SteveDeclerck
#1 Posted : Monday, March 13, 2017 2:58:36 AM(UTC)
Groups: Member
Joined: 9/30/2016(UTC)
Posts: 7

Thanks: 2 times
Hi,

When I try to access folders from my WCF service, it is working as long as the permissions of these folders are set to "Everyone". The "Everyone" group of users has full control. When permission of the folders I try to access is set to SYSTEM or ADMINISTRATOR, folders are no longer accesible from the service. The error is: Attempted to perform an unauthorized operation. The weird thing is, SYSTEM and ADMINISTRATOR have the same access rights : full control.

The Ultidev service is running under the system account of the server (default). And when I open the Ultidev Webserver Explorer, and check the 'Authentication' tab, authentication is set to 'anonymous'. I'm wondering if I have to change the configuration settings in order to have access to directories on the server?

Thanks a lot !
Best regards, S.
Ultidev Team
#2 Posted : Monday, March 13, 2017 9:54:43 AM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,228

Thanks: 28 times
Was thanked: 52 time(s) in 51 post(s)
Hi, Steve.

Troubleshooting access issues in ASP.NET can be quite tricky. If you go to http://localhost:7756 on the system where UWS is installed, it will provide guidance regarding where to start. The link to the Process Monitor utility on that page is broken though, as MS has moved it to https://technet.microsof.../sysinternals/bb896645.

Best regards,
UltiDev Team

Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
Rss Feed  Atom Feed
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.