Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Installation of UitiDev Web Server Pro
JaJaR
#1 Posted : Tuesday, February 14, 2017 6:08:43 PM(UTC)
Groups: Member
Joined: 2/14/2017(UTC)
Posts: 5
Location: CT

I cannot install the Web server program. I am running Windows 10 Pro with all updates. I have attached some log information. This is used with an application called StarShip for shipping solutions. I have looked at the forms and did not find a solution. Your help would be appreciated.

Thanks
Jack
File Attachment(s):
WebServerLogs.zip (27kb) downloaded 6 time(s).
Ultidev Team
#2 Posted : Wednesday, February 15, 2017 9:59:29 AM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,239

Thanks: 28 times
Was thanked: 55 time(s) in 54 post(s)
Hi, Jack.

Thanks for detailed error report submission. We saw in the event log that CAPI2 (encryption API) component has failed at the very start of the installation process, but to tell whether that is the root cause of the subsequent failure of the AppReg.exe that derailed the installation, we'd need to see another log file: "C:\Program Files (x86)\UltiDev\Web Server\AppRegTrace.txt". Can you please attach it to your reply?

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
JaJaR
#3 Posted : Wednesday, February 15, 2017 10:56:27 AM(UTC)
Groups: Member
Joined: 2/14/2017(UTC)
Posts: 5
Location: CT

There is no file in "C:\Program Files (x86)\UltiDev\Web Server\AppRegTrace.txt". The UltiDev folder in in C:\Program Files and only has the Web Server folder with the .txt file i included in the zip file. There is no AppRegTrace.txt file.

Ultidev Team
#4 Posted : Wednesday, February 15, 2017 11:10:23 AM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,239

Thanks: 28 times
Was thanked: 55 time(s) in 54 post(s)
Hi, Jack.

Could you please run the installation again, and when you get a failure window, take a look in the "C:\Program Files (x86)\UltiDev\Web Server" folder before you dismiss the error message window. Please see whether "AppRegTrace.txt" is there at that point.

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
JaJaR
#5 Posted : Wednesday, February 15, 2017 11:43:35 AM(UTC)
Groups: Member
Joined: 2/14/2017(UTC)
Posts: 5
Location: CT

I did the install again and when i got the error box up i looked in the C:\Program Files\Webser folder and do see the installation but there is no Appreg text file. The only text file is the one i included in the .zip. Also the installation is in the C:\Program File\UtilDev not under the C:\Program File (x86) folder.

Jack
JaJaR
#6 Posted : Thursday, February 16, 2017 10:58:58 AM(UTC)
Groups: Member
Joined: 2/14/2017(UTC)
Posts: 5
Location: CT

I have some updated information on the installation. I re-installed w10 Pro and this resolved some of the errors i was seeing on the installation. However i have different errors and have added some of the log file attached.
File Attachment(s):
Desktop.zip (41kb) downloaded 5 time(s).
Ultidev Team
#7 Posted : Friday, February 17, 2017 2:24:04 PM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,239

Thanks: 28 times
Was thanked: 55 time(s) in 54 post(s)
Hi, Jack.

AppRegTrace.txt you sent was quite helpful. It shows that UWS.Configuration dll installed on the system is of the very old version 14 (instead of 21). This could a remnant of an old UWS installation. Here are the steps we recommend to troubleshoot:
- Uninstall UWS if it's installed (probably not).
- Go to "C:\Windows\assembly" in Windows Explorer and delete any assembly starting with UWS or UltiDev.
- Go to "C:\Program Files\UltiDev\Web Server" folder and delete all non-.txt files that are still there, if any.
- Go to http://ultidev.com/download/ and download & install latest version of UWS.
- Go to "C:\Windows\assembly" and ensure that UWS.Configuraiton version 1.0.0.21 is there (as shown on the attachment).
- Install StarShip.

Please let us know whether this information was helpful.

Best regards,
UltiDev Team.
Ultidev Team attached the following image(s):
Ultidev Team attached the following image(s): UWS assemblies in GAC.png
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
JaJaR
#8 Posted : Saturday, February 18, 2017 11:06:16 AM(UTC)
Groups: Member
Joined: 2/14/2017(UTC)
Posts: 5
Location: CT

I removed the old version of the .DLL's and the installation installed correctly. I want to thank you for the excellent support you provided. I will be sending you a donation for your efforts.

One thing I did find is there is no uninstall for the Web Server. Is there a way to do an uninstall?

Thank's Again
Jack
Ultidev Team
#9 Posted : Saturday, February 18, 2017 8:27:43 PM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,239

Thanks: 28 times
Was thanked: 55 time(s) in 54 post(s)
Thanks, Jack.

We are happy we were able to help and really appreciate the donation.
In order to uninstall UWS, you could find the uninstaller by typing "uninstall UWS" in your Windows Start button's search box. Or find it in by navigating from Windows Start menu. UWS is not present in the Windows application list because uninstalling it may disrupt existing application, which people sometimes don't realize they have. Our uninstaller shows web applications that would be broken if UWS is uninstalled.

Best regards,
UltiDev Team.
Ultidev Team attached the following image(s):
Ultidev Team attached the following image(s): UWS uninstallation Win8.png
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
Rss Feed  Atom Feed
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.