Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Windows 8.1 Bug
CastleOS
#1 Posted : Friday, November 29, 2013 8:19:46 PM(UTC)
Groups: Member
Joined: 11/29/2013(UTC)
Posts: 5

Hello,
First, thank you for this great software! I wanted to let you know it appears the App Redirector may have an issue with Windows 8.1. I've tested it on several computers and can't get it to work, though hosted websites DO load correctly.

The only difference I can see is the redirector is running on clr2, and the hosted sites clr4, but I can't find a way to change the app redirector to clr4 to test whether that change would work.

Please let me know what you think and if there is anything I can do to help you test!

Thanks,
Chris
Ultidev Team
#2 Posted : Monday, December 2, 2013 9:31:40 AM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,239

Thanks: 28 times
Was thanked: 55 time(s) in 54 post(s)
Hi!

Sorry for the delayed reply. Thank you much for the positive feedback!
Could you please attach a screenshot of the error to your next post?

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
CastleOS
#3 Posted : Monday, December 2, 2013 5:38:45 PM(UTC)
Groups: Member
Joined: 11/29/2013(UTC)
Posts: 5

Ultidev Team;4797 wrote:
Hi!

Sorry for the delayed reply. Thank you much for the positive feedback!
Could you please attach a screenshot of the error to your next post?

Best regards,
UltiDev Team.


There's no error...you click on the desktop shortcut and it loads the link to the GoToApplication feature, which then fails to load...
Ultidev Team
#4 Posted : Tuesday, December 3, 2013 9:29:19 AM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,239

Thanks: 28 times
Was thanked: 55 time(s) in 54 post(s)
Hi,

Could you please let us know, when it fails to load, how does it manifest itself: do you get 404 error, 500 errors, an exception, wrong path, unresolved hostname?

We have tested a scenario where a simple redistributable web application installed on Windows 8.1. It has created a desktop shortcut pointing to the redirector, and clicking the shortcut worked well. Attached is the app we ran. Could you please try it and let us know whether it worked for you?

Best regards,
UltiDev.
File Attachment(s):
ASP.NET app redist demo with UWS and ISLE setup.zip (1,051kb) downloaded 99 time(s).
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
CastleOS
#5 Posted : Tuesday, December 3, 2013 4:21:55 PM(UTC)
Groups: Member
Joined: 11/29/2013(UTC)
Posts: 5

Ultidev Team;4804 wrote:
Hi,

Could you please let us know, when it fails to load, how does it manifest itself: do you 404 error, 500 errors, an exception, wrong path, unresolved hostname?

We have tested a scenario where a simple redistributable web application installed on Windows 8.1. It has created a desktop shortcut pointing to the redirector, and clicking the shortcut worked well. Attached is the app we ran. Could you please try it and let us know whether it worked for you?

Best regards,
UltiDev.


Hi, attached is the screenshot. This is the result of clicking the desktop icon that works on versions other than Windows 8.1.

CastleOS attached the following image(s):
CastleOS attached the following image(s): image[3].png
Ultidev Team
#6 Posted : Wednesday, December 4, 2013 1:01:59 AM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,239

Thanks: 28 times
Was thanked: 55 time(s) in 54 post(s)
Hi,

For whatever reason, access to ASP.NET 2.0 Temporary ASP.NET folder is not granted to NETWORK SERVICE user on your system. The problem could be caused by .NET Framework 2.0 installed after UWS itself, or if ACLing the folder failed somehow.

Please let us know if this information has helped.

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
CastleOS
#7 Posted : Wednesday, December 4, 2013 1:04:20 AM(UTC)
Groups: Member
Joined: 11/29/2013(UTC)
Posts: 5

Ultidev Team;4811 wrote:
Hi,

Access to ASP.NET 2.0 Temporary ASP.NET folder is not granted to NETWORK SERVICE user. You may either grant it manually.

Please let us know if this information has helped.

Best regards,
UltiDev Team.


Hi, the problem was caused by upgrading from Windows 8 to Windows 8.1. It worked under 8, then it didn't when the 8.1 install was complete.

Thanks,
Chris
Ultidev Team
#8 Posted : Wednesday, December 4, 2013 9:48:08 AM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,239

Thanks: 28 times
Was thanked: 55 time(s) in 54 post(s)
Hi, Chris.

Could you please clarify whether you were able to resolve the issue, and if so, which solution did you employ?

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
Ultidev Team
#9 Posted : Wednesday, January 8, 2014 11:49:04 PM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,239

Thanks: 28 times
Was thanked: 55 time(s) in 54 post(s)
Hi!

Here's the work-around.

First, the problem: if UWS was installed on Windows 8, or 7, and then upgraded to 8.1, 8.1 installer re-ACLs ASP.NET temporary files folder by revoking write access for Network Service user.

To fix the problem, please grant "Network Service" user write access to the following folders:
C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files
C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files
C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files
C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files

If any of the listed folders don't exist on your system, skip them - it's not going to cause any problems.

In the next UWS build (20) we are going to add re-ACLing to the RegRepair utility so this problem can be fixed by simply running it, or by reinstalling UWS.

Please let us know if this information helped solving the problem.

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
Guest
#10 Posted : Friday, January 10, 2014 9:54:51 AM(UTC)
Groups:
Joined: 11/1/2005(UTC)
Posts: 279

That's the answer I was looking for, thank you! Looking forward to the next build!
CastleOS
#11 Posted : Friday, January 10, 2014 9:55:28 AM(UTC)
Groups: Member
Joined: 11/29/2013(UTC)
Posts: 5

That's the answer I was looking for, thank you! Looking forward to the next build!
Ultidev Team
#12 Posted : Friday, January 10, 2014 5:45:38 PM(UTC)
Ultidev Team

Groups: Administration
Joined: 11/3/2005(UTC)
Posts: 2,239

Thanks: 28 times
Was thanked: 55 time(s) in 54 post(s)
We are working on the final workitem for this release, and if all goes well, we'll release build 20 around Jan 18-19.

Best regards,
UltiDev Team.
Please donate at http://www.ultidev.com/products/Donate.aspx to help us improve our products.
Rss Feed  Atom Feed
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.